My 84-89 Gauges are dark - is that normal?

Posted by Bryan Thompson on

Note:  This specifically addresses the issue that the cluster is dark.  If the issue with your cluster is bright, just not readable, see the Polarizing Film kit here

 

The short answer is...it depends.  It depends on whether the headlight switch is off or on.  It depends on how the headlight brightness control on the headlight switch is set.  It depends on whether it's day or night.  It depends on whether you're testing inside the garage, or outside in the sunlight.  It depends on the weather.  Really.  Here's how we test:

 

Start with the headlight switch set to off.  Note what happens for the first two seconds after you turn on the key.  It should turn on all segments and show them at full brightness. 

 

After that, the cluster image should resolve to show correct info and the lighting starts responding to light falling on the photocell.  The photocell is that 1/4" square hole at the top left of the cluster.  If you're in a garage, or testing in the shade, or at night, the cluster is going to be dark, because the photocell senses that it's dark out. 

 

Next, shine a light in the upper left corner of the cluster where the photocell opening is.  Wait a few seconds.  It should brighten completely and show correct info on the LCDs.

 

Next put a piece of black tape over the photocell.  Wait abut 3-4 minutes for the smoothing algorithm to let the cluster dim, or until the cluster goes dark.  You should still see correct info on the LCDs, but they should be max dimness.

 

If it does the things above, it's responding the way it should to light falling on the photocell.

 

Next let's test the headlight switch.  Leave the tape on the photocell to simulate night, and turn on the headlights.  Rotate the headlight control full clockwise.  The cluster should be mid-bright, the way you need it to be during night driving. 

 

Rotate the headlight knob full counterclockwise.  The cluster should dim to minimum brightness.

 

If it does those things, it is likely that your cluster is working as it should.  If it looks dark, it's likely because the car is in a dark location.  Drive it into the light, and the gauges should light up again. 

 

Go ahead and take the tape off of the photocell at this point.  We're done testing things that can be influenced by light falling on the photocell.

 

If the cluster does not do the things above, we need to determine if the cluster is getting all of the information it needs to do its job, like power, ground, and info about what the headlight switch is set to. 

 

Check the fuses marked CLSTR, LCD, INST and TAIL. Check them for continuity.  A well-known failure mode is for them to become loose in the fuse holder contacts. 

 

If that works, it's time to measure what's happening at the cluster wiring harness connector.  Click Here for a diagram of what wire is where on the wiring harness connector.  First let's check the factory grounds.  Get a multimeter and set it to DC Volts.  Put the black probe on the battery negative terminal, and put the red probe on each of the following wires in the cluster connector:  D1 and D3.  With the key on, the voltage between those two points needs to be 0.2V or less.  If not, there's a problem with the factory grounds.

 

Next let's check the headlight switch.  There are outputs from the headlight switch that tell the cluster if the headlights are on or not, and that tells the cluster what brightness setting is set on the headlight switch.    Get a multimeter and set it to DC Volts.  Put the black probe on the battery negative terminal.  Put the red probe on terminal C6 of the cluster wiring harness connector.  With the key on, you should measure battery voltage with the headlight switch on, and 0V with the headlight switch off.  Put the red probe on terminal C9 of the wiring harness connector.  With the key on and headlight switch on, you should measure 6V with the headlight knob set to full dim (counterclockwise), and you should measure battery voltage with the headlight knob set to full bright (clockwise).  If not, there may be a problem with the headlight switch. 

If all that checks out, the issue may be inside the cluster.  Then again, it may be an intermittent fault with something you checked above.  It is common for faulty power connectors, faded photocells, bad bulbs and bad power supplies inside the cluster to cause the cluster not to light up.  Less common failures include a failure of the IC which responds to the headlight switch inputs that say how bright to make the cluster. 

 

Thank you,

Bryan Thompson, Founder of batee.com Corvette Parts and Repair


Share this post



Newer Post →


Leave a comment

Please note, comments must be approved before they are published.